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Introduction 

SeismoBuild  is a Finite Element package for structural assessment, capable of carrying out all the Code 
defined checks, taking into account both geometric nonlinearities and material inelasticity. 

The software consists of six main modules: the Building Modelling  module, in which it is possible to 
define the input data of the structural model, the Code Requirements  module, whereby the Code-based 
parameters and options are defined, the Eigenvalue Analysis  and Pushover Analysis  modules, where 
the selected analyses are carried out and their  results are obtained, the Checks module, in which all the 
checks for the structural members, according to the selected Code, are carried out and finally the Report  
module to output the results of the building assessment; all is handled through a completely visual 
interface .  

With the Building Modeller facility  the user can create regular or irregular 3D structural models on 
the fly. The whole process takes no more than a few minutes. No input or configuration files, 
programming scripts or any other time-consuming and complex text editing procedures are required. 
Moreover, the Processor in the Eigenvalue and Pushover analysis modules, features real-time plotting 
of displacement curves and deformed shape of the structure, together with the possibility of pausing 
and re-starting the analysis, whilst the Post-Processor, where the results of the analyses are exported, 
offers advanced post-processing facilities, including the ability to custom-format all derived plots and 
deformed shapes, thus increasing the productivity of users; it is also possible to create AVI movie files 
to better illustrate the sequence of structural deformation. 

 

Structure of the software  

The software is fully integrated with the Windows environment. All information visible within the 
graphical interface of SeismoBuild can be copied to external software applications (e.g. to word 
processing programs, such as Microsoft Word), including output data, high quality graphs, the models' 
deformed and undeformed shapes and much more. 

 

Building Modelling

Code Requirements

Eigenvalue Analysis

Analysis (linear or nonlinear)

Checks

Report



 

General 

SYSTEM REQUIREMENTS 

To use SeismoBuild , we suggest: 

¶ ! 0# ɉÏÒ Á ȰÖÉÒÔÕÁÌ ÍÁÃÈÉÎÅȱɊ ×ÉÔÈ ÏÎÅ ÏÆ ÔÈÅ ÆÏÌÌÏ×ÉÎÇ ÏÐÅÒÁÔÉÎÇ ÓÙÓÔÅÍÓȡ Windows 7 and later 
versions of Windows (64-bit);  

¶ 8 GB RAM; 
¶ Screen resolution set to 1366x768 pixels or higher; 
¶ An Internet connection (better if a broadband connection) for the registration of the software. 

INSTALLING/UNINSTALLING THE SOFTWARE 

Installing the software 

Follow the steps below in order to install SeismoBuild : 

1. Download the version of the program from: www.seismosoft.com/downloads  
2. Save the application on your computer and launch it.  

  

Installation wizard (first window)  

3. Click the Next button to proceed with the installation. The License Agreement appears on the 
screen. Please, read it carefully and accept the terms by checking the box. 

4. Click the Next button. On the next request to select the destination folder, click the Next button 
ÁÇÁÉÎ ÔÏ ÉÎÓÔÁÌÌ ÔÏ ÔÈÅ ȬÄÅÆÁÕÌÔȭ ÆÏÌÄÅÒ ÏÒ ÃÌÉÃË ÔÈÅ #ÈÁÎÇÅ ÂÕÔÔÏÎ ÔÏ ÉÎÓÔÁÌÌ ÔÏ Á ÄÉÆÆÅÒÅÎÔ ÏÎÅȢ 

5. Click the Install button and wait until the software is installed. 
6. At the end of the procedure, click Finish to exit the wizard. 

http://www.seismosoft.com/downloads
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Installation wizard (last window)  

Uninstalling the software 

To remove the software from the computer: 

1. Open the Start menu. 
2. Click Settings. 
3. Click System on the Settings menu. 
4. Select Apps & features from the left pane.  
5. Select the program from the list of all the installed apps. 
6. Click the Uninstall button that appears. 

OPENING THE SOFTWARE AND REGISTRATION OPTIONS 

To launch SeismoBuild, select Start > Programs or All Programs > Seismosoft > SeismoBuild 2024> 
SeismoBuild 2024Ȣ 4ÈÅ ÆÏÌÌÏ×ÉÎÇ ÒÅÇÉÓÔÒÁÔÉÏÎȭÓ ×ÉÎÄÏ× ×ÉÌÌ ÁÐÐÅÁÒȡ 

 

SeismoBuild  Registration Window  

Before using the software you must choose one of the following options: 

1. Continue using the program in trial mode. 
2. Obtain an academic license by providing a valid academic e-mail address. 



General 15 

 

 

3. Acquire a commercial license. 

 

  

Registration Form  

NOTE: If you choose option 2 or 3, then you have to register using the provided license . 

IMPORTANT: Regarding the license keys please note that , as indicated in the message that appears 

before the opening of the m ain window of the program, the licenses of version 2023 and older  are not 

valid in Seismo Build  2024 . Users are thus invited to request a new license . 



 

Quick Start 

This chapter will walk you through your first analyses with SeismoBuild . 

SeismoBuild has been designed with both ease-of-use and flexibility in mind. Our goal is to increase the 
productivity significantly, to the point that the assessment of a multi-storey RC building may be 
completed within a few minutes, including the creation of the report and the CAD drawings to be 
submitted to the client. It is actually much easier to use SeismoBuild than it is to describe. You will see 
that once you have grasped a few important concepts, the entire process is quite intuitive. The model 
that you will create is packed with features and can simulate efficiently and accurately real structures. 

TUTORIAL N.1 ς ASSESSMENT OF A TWO-STOREY BUILDING 

Problem Description 

Let us try to model a three dimensional, two-storey reinforced concrete building for which you are asked 
to assess its capacity according to the Eurocodes. The Building Modeller facility offers a fast and easy 
definition of the building. The geometry of the first and second floor is shown in the corresponding plan-
views below:  

 

Plan view of 1st floor of the building  
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NOTE: A movie describing ɬutorial N.1 ÃÁÎ ÂÅ ÆÏÕÎÄ ÏÎ 3ÅÉÓÍÏÓÏÆÔȬÓ YouTube channel.  
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Plan view of 2 nd floor of the building  

Getting started: a new project 

When opening SeismoBuild a window ÁÐÐÅÁÒÓ ÆÏÒ ÓÅÌÅÃÔÉÎÇ ÔÈÅ ÎÅ× ÐÒÏÊÅÃÔȭÓ structural Code, units and 
rebar typology. The available options depending on the edition are Eurocode 8, ASCE 41-17 (American 
Code for Seismic Evaluation and Retrofit of Existing Buildings), NTC-18 (Italian National Seismic Code), 
NTC-08 (Italian National Seismic Code), KANEPE (Greek Seismic Interventions Code) and TBDY (Turkish 
Seismic Evaluation Building Code), SI and Imperial Units, and European sizes and US sizes for the rebar 
typology. 

    

Select Structural Code & Units window  

 

6.00

5
.0

0
3

.5
5

2
.6

5

6.15

1.45

9
.7

0

1.48



18 SeismoBuild User Manual 

 

When selecting the Building Modelling module command, the Building Modeller initialisation window 
ÏÐÅÎÓȟ ÆÒÏÍ ×ÈÉÃÈ ÔÈÅ ÎÕÍÂÅÒ ÏÆ ÓÔÏÒÅÙÓȟ ÔÈÅ ÓÔÏÒÅÙÓȭ ÈÅÉÇÈÔÓ, and other basic settings may be defined.  

For this tutorial the following settings have been chosen: 

¶ Eurocode 8, Part 3 
¶ SI Units 
¶ European sizes for rebar typology 
¶ 2 Storeys 
¶ 3ÔÏÒÅÙÓȭ ÈÅÉÇÈÔÓȡ σÍ 
¶ Do not accept beams with free span less than: 0.1m 
¶ Include beam effective widths 

  

Building Modeller Initialisation module -Structural Configuration  

Proceed by clicking OK. 

)Î ÏÒÄÅÒ ÔÏ ÆÁÃÉÌÉÔÁÔÅ ÔÈÅ ÄÅÆÉÎÉÔÉÏÎ ÏÆ ÔÈÅ ÅÌÅÍÅÎÔÓȭ ÇÅÏÍÅÔÒÙ ÁÎÄ ÌÏÃÁÔÉÏÎȟ Á #!$ ÄÒÁ×ÉÎÇ ÃÁÎ ÂÅ 

imported from the main menu (File > Import DWG...) or through the corresponding toolbar button . A 
window appears for selecting the DWG/DXF units, and the user is given the possibility to move the 
drawing to the (0,0) origin of the CAD coordinates. 
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Building Modeller ɀ Imported Cad Settings  

 

Building Modeller ɀ CAD drawing insertion  

Begin inserting the structural members from the main menu (Insert > Insert Rectangular Column) or 

through the  toolbar button for rectangular columns. Alternatively, select one of the other available 

column sections, L-shaped ( ), T-shaped ( ), circular column ( ) or their jacketed counterparts. 
The Properties Window of the column will appear on the right-hand side of the screen and the user can 
define its geometry, the foundation level, the longitudinal and transverse reinforcement, its material 
properties, the FRP wrapping and the Code-based settings for structural members. In the material sets 
ÍÏÄÕÌÅ ÔÈÅ ÍÅÍÂÅÒȭÓ ÃÏÎÃÒÅÔÅ ÁÎÄ ÒÅÉÎÆÏÒÃÅÍÅÎÔ ÓÔÒÅÎÇÔÈ values are determined. The material set 
should be defined for every structural member. By default there are two material sets in the program, 
one for the existing members, called Default_Existing, which is used in the current tutorial, and one for 
the new members added for rehabilitation, called Default_New. Users may add new material sets or edit 
the existing ones, but they cannot remove the default material schemes. 
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Building Modeller ɀ Material Sets  

 

Building Modeller ɀ Modify Existing Material S cheme 

By clicking on the Advanced Member Properties button users may define the settings of the structural 
member according to the selected Code. 
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Building Modeller ɀ Advanced Member Properties  

Further, the 'insertion point ' of the element can be chosen by clicking on the corner, middle or side points 
of the section's plot on the Properties Window. You are allowed to change the sections dimensions by 
clicking on them, whereas the rotation of the column on plan-view can be changed by the 0o, 90o, 180o 
and 270o buttons or by assigning the proper angle on the corresponding editbox of the Properties 
Window. Although different foundation levels may be defined for the columns of the first floor, for the 
purpose of the current tutorial a common foundation level of -1000mm is assigned to all the columns. 

 

Building Modeller ɀ Column Element Properties  
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The dimensions and the reinforcement of the members (columns, beams and walls) of the first and 
second floor are shown in the following tables: 

Columns 

of 1st floor  

Height  

(mm)  

Width  

(mm)  

Longitudinal reinforcement  Transverse 
reinforcement  

C1 400 400 4Å18+4Å16 Å10/10  

C2 400 400 4Å18+4Å16 Å10/10  

C3 750 250 4Å16+8Å14 Å10/10  

C4 300 500 6Å18 Å10/10  

C5 300 500 6Å18 Å10/10  

C6 300 500 6Å20 Å10/10  

C7 250 500 4Å20+2Å16 Å10/10  

C8 300 500 6Å20 Å10/10  

W9 250 1800 (4Å16+8Å14)+ 
#Å10/20+(4Å8/m²)  

Å10/10  

 

Beams 
of 1st 
Floor  

Height  

(mm)  

Width  

(mm)  

Reinforcement 
at the Start of 
the beam 

Reinforcement 
at the Middle 
of the beam 

Reinforcement 
at the End of 
the beam 

Transverse 
reinforcement  

B1 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o3Å14 u4Å14 Å8/10  

B2 500 250 o3Å14 u4Å14 o2Å14 u4v14 o4Å16 u4Å14 Å8/10  

B3 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o3Å14 u4Å14 Å8/10  

B4 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o2fÅ20 u4Å14 Å8/10  

B5 500 250 o2Å14 u4Å14 o2Å14 u4Å14 o3fÅ14 u4Å14 Å8/10  

B6 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o2Å14 u4Å14 Å8/10  

B7 500 250 o3Å20 u2Å14 o4Å14 u2Å14 o3Å20 u2Å14 Å8/10  

B8 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o2Å14 u4Å14 Å8/10  

B9 500 250 o2Å14 u4Å14 o2Å14 u4Å14 o2Å18 u4Å14 Å8/10  

B10 500 250 o4Å16 u4Å14 o2Å14 u4Å14 o2Å18 u4Å14 Å8/10  

B11 500 250 o2Å18 u4Å14 o2Å14 u4Å14 o2Å14 u4Å14 Å8/10  
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Beams 
of 1st 
Floor  

Height  

(mm)  

Width  

(mm)  

Reinforcement 
at the Start of 
the beam 

Reinforcement 
at the Middle 
of the beam 

Reinforcement 
at the End of 
the beam 

Transverse 
reinforcement  

B12 500 250 o2Å14 u4Å14 o2Å14 u4Å14 o3Å18 u4Å14 Å8/10  

B13 500 250 o2Å18 u4Å14 o2Å14 u4Å14 o3Å14 u4Å14 Å8/10  

B14 500 250 o2Å18 u4Å16 o2Å16 u4Å16 o2Å16 u4Å16 Å8/10  

B15 500 250 o4Å16 u2Å16 o4Å16 u2Å16 o4Å16 u2Å16 Å8/10  

 

columns  

of 2nd floor  

Height  

(mm)  

Width  

(mm)  

Longitudinal reinforcement  Transverse 
reinforcement  

C2 400 400 4Å18+4Å16 Å10/10  

C3 750 250 4Å16+8Å14 Å10/10  

C5 300 500 4Å20+2Å16 Å10/10  

C6 300 500 6Å20 Å10/10  

C7 250 500 4Å20+2Å16 Å10/10  

W9 250 1800 (4Å16+8Å14)+# Å10/20+(4Å8/m²)  Å10/10  

 

Beams 
of 2nd 
Floor  

Height  

(mm)  

Width  

(mm)  

Reinforcement 
at the Start of 
the beam 

Reinforcement 
at the Middle 
of the beam 

Reinforcement 
at the End of 
the beam 

Transverse 
reinforcement  

B1 500 250 o4Å16 u4Å14 o2Å14 u4Å14 o4Å16 u4Å14 Å8/10  

B2 500 250 o2Å18 u4Å14 o2Å14 u4Å14 o2Å18 u4Å14 Å8/10  

B3 500 250 o2Å14 u4Å14 o2Å14 u4Å14 o3Å14 u4Å14 Å8/10  

B4 500 250 o3Å20 u4Å14 o2Å14 u4Å14 o2Å14 u4Å14 Å8/10  

B5 500 250 o2Å18 u4Å14 o2Å14 u4Å14 o3Å14 u4Å14 Å8/10  

B6 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o2Å14 u4Å14 Å8/10  

B7 500 250 o2Å14 u4Å14 o2Å14 u4Å14 o3Å18 u4Å14 Å8/10  

B8 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o3Å14 u4Å14 Å8/10  

B9 500 250 o3Å14 u4Å14 o2Å14 u4Å14 o2Å14 u4Å14 Å8/10  
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B10 500 250 o4Å16 u2Å16 o4Å16 u2Å16 o4Å16 u2Å16 Å8/10  

After clicking on the Insert Wall button, ÔÈÅ 7ÁÌÌȭÓ 0ÒÏÐÅÒÔÉÅÓ 7ÉÎÄÏ× appears, where the dimensions, 
the reinforcement pattern (longitudinal and transverse at the two edges and at the middle), the pseudo-
columns' length, the foundation level, the material set, the FRP wrapping and the advanced code-based 
properties can be defined. Select the insertion line by clicking on any of the three lines on the geometry 
view (the left is the chosen one in the current example), and insert the structural wall by outlining its 
two edges on the Main Window. 

 

Building Modeller ɀ Wall Element Properties  

Insert the beams from the main menu (Insert > Insert Beam) or through the corresponding toolbar 

button , in a similar fashion to the walls. Again, it is possible to easily define the geometry (width and 
depth), the reinforcement (longitudinal and transverse reinforcement at the start, middle and end 
sections), the material set, the advanced properties and select the insertion line on the plan view by 
clicking on the preferred axis (left, centre or right). Additional distributed load  may also be defined, 
which will serve to define any permanent load not associated to the self-weight of the structural system 
(e.g. finishings, infills, etc). 
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Building Modeller ɀ Insert Elements  

 

Building Modeller ɀ Beam Element Properties  

In order to insert the slabs go to the main menu (Insert > Insert Slab) or click the  toolbar button, 
ÁÓÓÉÇÎ ÔÈÅ ÓÌÁÂȭÓ ÐÒÏÐÅÒÔÉÅÓ (height, reinforcement, additional permanent and live loads), and click on 
any closed area surrounded by structural elements (columns, walls and beams). A "Type of Loaded Area" 
button is available so that the live loads are automatically assigned according to the loading category of 
the selected Code. It is noted that the self-weight of the slabs is automatically calculated according to the 
ÓÌÁÂÓȭ ÇÅÏÍÅÔÒÙȟ ÍÁÔÅÒÉÁÌÓ ÁÎÄ ÓÐÅÃÉÆÉÃ ×ÅÉÇÈÔȢ Once the slab is defined, its support conditions may be 
modified by just clicking on the corresponding boundaries of the slab's diagram on the Properties 




















































































































































































































































































































































































































































































































































































































































































































































